Geen categorie

EVPN-VXLAN #draft

Just a draft.

set version 17.4R1.16
set system host-name north
set system root-authentication encrypted-password “$6$o0ranQzS$7.EKJYD5G5FsvXwMgW0RDSPfGdjm5ew2JfNqjuSdsxQZE/vVWC2l2lvOpx4PGUqjHIYwvQQYKEmNLkXW25wkN0”
set system syslog user * any emergency
set system syslog file messages any notice
set system syslog file messages authorization info
set system syslog file interactive-commands interactive-commands any
set system processes dhcp-service traceoptions file dhcp_logfile
set system processes dhcp-service traceoptions file size 10m
set system processes dhcp-service traceoptions level all
set system processes dhcp-service traceoptions flag all
set interfaces ge-0/0/0 mtu 1600
set interfaces ge-0/0/0 unit 0 family inet address 10.0.0.9/30
set interfaces ge-0/0/0 unit 0 family mpls
set interfaces ge-0/0/1 mtu 1600
set interfaces ge-0/0/1 unit 0 family inet address 10.0.0.1/30
set interfaces ge-0/0/1 unit 0 family mpls
set interfaces ge-0/0/9 vlan-tagging
set interfaces ge-0/0/9 encapsulation flexible-ethernet-services
set interfaces ge-0/0/9 unit 10 encapsulation vlan-bridge
set interfaces ge-0/0/9 unit 10 vlan-id 10
set interfaces fxp0 unit 0 family inet dhcp vendor-id Juniper-vmx-VM5B9A6136F0
set interfaces lo0 unit 0 family inet address 172.16.0.1/32
set routing-options autonomous-system 65000
set protocols rsvp interface all
set protocols mpls no-cspf
set protocols mpls label-switched-path to-south to 172.16.0.3
set protocols mpls label-switched-path to-east to 172.16.0.2
set protocols mpls label-switched-path to-west to 172.16.0.4
set protocols mpls interface all
set protocols bgp family evpn signaling
set protocols bgp group ibgp type internal
set protocols bgp group ibgp neighbor 172.16.0.3 local-address 172.16.0.1
set protocols bgp group ibgp neighbor 172.16.0.2 local-address 172.16.0.1
set protocols bgp group ibgp neighbor 172.16.0.4 local-address 172.16.0.1
set protocols ospf area 0.0.0.0 interface lo0.0 passive
set protocols ospf area 0.0.0.0 interface fxp0.0 disable
set protocols ospf area 0.0.0.0 interface ge-0/0/0.0
set protocols ospf area 0.0.0.0 interface ge-0/0/1.0
set routing-instances evpn10 vtep-source-interface lo0.0
set routing-instances evpn10 instance-type evpn
set routing-instances evpn10 vlan-id 10
set routing-instances evpn10 interface ge-0/0/9.10
set routing-instances evpn10 vxlan vni 10
set routing-instances evpn10 vxlan multicast-group 224.0.0.0
set routing-instances evpn10 vxlan encapsulate-inner-vlan
set routing-instances evpn10 vxlan decapsulate-accept-inner-vlan
set routing-instances evpn10 route-distinguisher 172.16.0.1:10
set routing-instances evpn10 vrf-target target:10:10
set routing-instances evpn10 protocols evpn
set routing-instances evpna instance-type vrf
set routing-instances evpna route-distinguisher 172.16.0.1:11
set routing-instances evpna vrf-target target:65000:11
set routing-instances evpna vrf-table-label

About Sebastiaan Koetsier

Leave a Reply

Your email address will not be published. Required fields are marked *