Geen categorie

Migrating off a big Layer2 domain

 

Here is my lab:

4 x vMX
4 x Arista vEOS
4 x VPC

MX configurations:

interfaces {
ge-0/0/0 {
description "IX5 <> GLO";
mac 50:01:00:01:00:02;
unit 0 {
family inet {
address 10.0.1.1/30;
}
family iso;
family mpls;
}
}
ge-0/0/1 {
description "IX5 <> EN-1";
mac 50:01:00:01:00:03;
unit 0 {
family inet {
address 10.0.1.5/30;
}
family iso;
family mpls;
}
}
ge-0/0/2 {
description "IX5 <> EN2";
mac 50:01:00:01:00:04;
unit 0 {
family inet {
address 10.0.1.13/30;
}
family iso;
family mpls;
}
}
ge-0/0/3 {
flexible-vlan-tagging;
encapsulation flexible-ethernet-services
unit 100 {
encapsulation vlan-bridge;
vlan-id 100;
}

}
lo0 {
unit 0 {
family inet {
address 10.10.10.1/32;
}
family iso {
address 49.0001.1000.0000.0001.00;
}
}
}
}
routing-options {
router-id 10.10.10.1;
autonomous-system 8315;
forwarding-table {
chained-composite-next-hop {
ingress {
evpn;
}
}
}
}
protocols {
rsvp {
interface ge-0/0/0.0;
interface ge-0/0/1.0;
interface ge-0/0/2.0;
interface all;
}
mpls {
label-switched-path ix5-to-en1 {
to 10.10.10.3;
ldp-tunneling;
}
label-switched-path ix5-to-en2 {
to 10.10.10.4;
ldp-tunneling;
}
label-switched-path ix5-to-glo {
to 10.10.10.2;
ldp-tunneling;
}

group IBGP {
type internal;
local-address 10.10.10.1;
family inet {
unicast;
}
family inet-vpn {
unicast;
}
family l2vpn {
signaling;
}
family evpn {
signaling;
}
neighbor 10.10.10.2;
neighbor 10.10.10.3;
neighbor 10.10.10.4;
}
}
ospf {
traffic-engineering;
area 0.0.0.0 {
interface lo0.0 {
passive;
}
interface ge-0/0/0.0;
interface ge-0/0/1.0;
interface ge-0/0/2.0;
}
}
ldp {
interface ge-0/0/0.0;
interface ge-0/0/1.0;
interface ge-0/0/2.0;
}
}
routing-instances {
evpn {
instance-type evpn;
vlan-id 100;
interface ge-0/0/3.100;
route-distinguisher 10.10.10.1:100;
vrf-target target:100:100;
protocols {
evpn {
interface ge-0/0/3.100;
}
}
}
}

Configurations are identical for all vMX’s except (loopback) IP addresses etc.

De Arista’s have an tagged (trunk) uplink on eth1 and access on eth2 which connect to a VPC. This works like a charm.

Note: this blog needs to be worked out more.

Tagged , , , , , , ,

About Sebastiaan Koetsier

Leave a Reply

Your email address will not be published. Required fields are marked *